import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Tap on a clip to paste it in the text box.";
final String string = "Tap on a clip to paste it in the text box.Use the edit icon to pin, add or delete clips.Welcome to Gboard clipboard, any text you copy will be saved here.\n"
+ "basserotwo\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}