#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([aeiou])\1"
Local $sString = "De Haan" & @CRLF & _
"Greenberg" & @CRLF & _
"Khoo" & @CRLF & _
"Gee" & @CRLF & _
"Greene" & @CRLF & _
"Lee" & @CRLF & _
"Bloom" & @CRLF & _
"Feeney" & @CRLF & _
"Biegeleisen"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")