use strict;
my $str = '0.32 100.00 5.6 0.27 98% 12.2% 1.01 0.99% 0.99 13.13 1.10';
my $regex = qr/(?<!\.)(\b(?:\d{2,3}|[2-9])(?:\.\d+)?\b|\b1\.(?:1\d?|0[1-9])\b)(?!%|\.)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}