re = /([Hh][Ee][Yy](?R)?oh)/m
str = 'heyoh heyyoh hEyHeYohoh hey oh heyhey hEyHeYHEyohohoh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end