$re = '/./m';
$str = 'I\'m sorry, Dave. I\'m afraid I can\'t do that.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);