re = /\\[nrt]/m
str = '`\\n`, `\\r`, and `\\t` are whitespace characters, `\\.`, `\\\\` and `\\[` are not.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end