package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z][a-z][^y ]`)
var str = `day dog hog hay bog bay ray rub`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}