$re = '/[a-zA-Z_$]\w\w/m';
$str = '__e $123 3.2 fo Barr a23mm ab x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);