$re = '/\d+\.*\d*[KMGT]B/m';
$str = '11TB 13 14.4MB 22HB 9.9GB TB 0KB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);