using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(2[1-9]|[3-9]\d|1\d\d)|([0-9]|1[0-9]|20)";
string input = @"7 10 17 18 19 20 21 22 23 24 30 40 100 120";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}