$re = '/(2[1-9]|[3-9]\d|1\d\d)|([0-9]|1[0-9]|20)/m';
$str = '7 10 17 18 19 20 21 22 23 24 30 40 100 120';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);