$re = '/([^aeiou ]\w*)|(\w+)/m';
$str = 'pds6f uub 24r2gp ewqrty l ui_op';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);