package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w{4,})|(\w{1,3})`)
var str = `Kim Jobs Xu Cloyd Mohr Ngo Rock`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}