$re = '/\"\b[^"]{0,5}\b\"|\"\b[^"]+\s[^"]*\b\"/m';
$str = '"thefollowingpasswordistooshort" "C++"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);