#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)/upload/[^/]+/"
Local $sString = "<div class="slide"><a class="slide__card fancybox" rel="gallery1" href="/upload/f2d/f2d520b5d31920e1227c4414cd4f214a.jpg"><img src="/upload/f2d/700_525_1/f2d520b5d31920e1227c4414cd4f214a.jpg" /><span class="zoom-cell"></span></a></div><div class="slide"><a class="slide__card fancybox" rel="gallery1" href="/upload/3ff/3ff30ba3ec6e5d5b1b753b3749ff601c.jpg"><img src="/upload/3ff/700_525_1/3ff30ba3ec6e5d5b1b753b3749ff601c.jpg" /><span class="zoom-cell"></span></a></div><div class="slide"><a class="slide__card fancybox" rel="gallery1" href="/upload/0aa/0aa859109670c4aac06eaee7eec33d6f.jpg"><img src="/upload/0aa/700_525_1/0aa859109670c4aac06eaee7eec33d6f.jpg" /><span class="zoom-cell"></span></a></div><div class="slide"><a class="slide__card fancybox" rel="gallery1" href="/upload/b56/b56537718cabbaa75e0b56056ae8a1db.jpg"><img src="/upload/b56/700_525_1/b56537718cabbaa75e0b56056ae8a1db.jpg" /><span class="zoom-cell"></span></a></div><div class="slide"><a class="slide__card fancybox" rel="gallery1" href="/upload/e99/e99800f9ece27c61fb0c395aed4423d1.jpg"><img src="/upload/e99/700_525_1/e99800f9ece27c61fb0c395aed4423d1.jpg" /><span class="zoom-cell"></span></a></div>"
Local $sSubst = "/upload/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)