using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G|^)\d";
string substitution = @"X";
string input = @"aaaaaaaaaa 123
5aaaaaaaaa 45
4707aaaaaa
aaaaaaaaaa
923aaaaaaa";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}