const regex = /(?:\G|^)\d/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G|^)\\d', 'gm')
const str = `aaaaaaaaaa 123
5aaaaaaaaa 45
4707aaaaaa
aaaaaaaaaa
923aaaaaaa`;
const subst = `X`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);