re = /(?:\G|^)\d/m
str = 'aaaaaaaaaa 123
5aaaaaaaaa 45
4707aaaaaa
aaaaaaaaaa
923aaaaaaa'
subst = 'X'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result