import Foundation
let pattern = #"(?:\G|^)\d"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
aaaaaaaaaa 123
5aaaaaaaaa 45
4707aaaaaa
aaaaaaaaaa
923aaaaaaa
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)