# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/(?!.*\.)[^\\/]+$/$0\\//gm;t' <<< "www.mysite.com/page
www.mysite.com/page/
www.mysite.com/file.php
www.mysite.com/file.jpg
www.mysite.com/file.html
www.mysite.com/file.doc"