#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(January|February|March|April|May|June|July|August|September|October|November|December|[\d ]+)|."
Local $sString = "1 circa February 1950" & @CRLF & _
" testing July August Septiembre Octubre 7 8 9 10 10b ... 101" & @CRLF & _
"(c. 1929)"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)