package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(January|February|March|April|May|June|July|August|September|October|November|December|[\d ]+)|.`)
var str = `1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101
(c. 1929)`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}