$re = '/Empfänger\s+(.*)/m';
$str = 'Empfänger Max Mustermann
99999 Musterstadt * Musterstraße 5
Lieferavis max.muster@mustermail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);