#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^\/{2}(?!\/).*$"
Local $sString = "https://docs.asciidoctor.org/asciidoc/latest/comments/" & @CRLF & _
"" & @CRLF & _
"ffds" & @CRLF & _
"//dfdfds" & @CRLF & _
"// kfjdkf lkdsfj lf //" & @CRLF & _
"/// not a comment" & @CRLF & _
"//// not a comment" & @CRLF & _
"" & @CRLF & _
"//" & @CRLF & _
"" & @CRLF & _
"// A single-line comment."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")