using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\/{2}(?!\/).*$";
string input = @"https://docs.asciidoctor.org/asciidoc/latest/comments/
ffds
//dfdfds
// kfjdkf lkdsfj lf //
/// not a comment
//// not a comment
//
// A single-line comment.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}