$re = '/(?m)^\/{2}(?!\/).*$/m';
$str = 'https://docs.asciidoctor.org/asciidoc/latest/comments/
ffds
//dfdfds
// kfjdkf lkdsfj lf //
/// not a comment
//// not a comment
//
// A single-line comment.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);