using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|(.+?)\|";
string input = @"PROTEIN\t1\t0\ttr|Q6ZN40|Q6ZN40_HUMAN\t\t-1\t;;;;;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}