# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"content=\""
test_str = ("<!DOCTYPE HTML><html lang=\"en\"><head><meta charset=\"utf-8\"><title>AlifPay</title><base href=\"/web/\"><meta name=\"viewport\" content=\"width=device-width,initial-scale=1\"><meta name=\"stk\" content=\"1lPxBhJKqRKUG6q73mQt4wQoD5I\"><link rel=\"icon\" type=\"image/x-icon\" href=\"./favicon.png\"><link href=\"styles.99f15c62ba66cd524e55.bundle.css\" rel=\"stylesheet\"/></head><body><app-root></app-root><script type=\"text/javascript\" src=\"inline.aced06935de18d27acc6.bundle.js\"></script><script type=\"text/javascript\" src=\"polyfills.34df2d66b4f714bfa1ad.bundle.js\"></script><script type=\"text/javascript\" src=\"main.0cea576e7bb8eeaea0e1.bundle.js\"></script></body></html>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.