package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(INC\d{4,8})|(\d{5,8}).*`)
var str = `INC4312 9/4/2022
12345
1234
9/4/2022`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}