#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^\h*<VirtualHost.*?>.*?\R\h*<\/VirtualHost>"
Local $sString = " <VirtualHost *:80>" & @CRLF & _
" ServerName localhost" & @CRLF & _
" DocumentRoot c:/wamp/www" & @CRLF & _
" <Directory "c:/wamp/www/">" & @CRLF & _
" Options +Indexes +Includes +FollowSymLinks +MultiViews" & @CRLF & _
" AllowOverride All" & @CRLF & _
" Require local" & @CRLF & _
" </Directory>" & @CRLF & _
" </VirtualHost>" & @CRLF & _
" <VirtualHost *:8080>" & @CRLF & _
" ServerName testing.com" & @CRLF & _
" DocumentRoot c:/wamp/www/testing.com" & @CRLF & _
" <Directory "c:/wamp/www/testing.com">" & @CRLF & _
" Options +Indexes +Includes +FollowSymLinks +MultiViews" & @CRLF & _
" AllowOverride All" & @CRLF & _
" Require local" & @CRLF & _
" </Directory>" & @CRLF & _
" </VirtualHost>" & @CRLF & _
" <VirtualHost 127.0.0.1:80>" & @CRLF & _
" ServerName testing2.com" & @CRLF & _
" DocumentRoot c:/wamp/www/testing2.com" & @CRLF & _
" <Directory "c:/wamp/www/testing2.com">" & @CRLF & _
" Options +Indexes +Includes +FollowSymLinks +MultiViews" & @CRLF & _
" AllowOverride All" & @CRLF & _
" Require local" & @CRLF & _
" </Directory>" & @CRLF & _
" </VirtualHost>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")