import re
regex = re.compile(r"^((?:(?:[^\"\n;]*\"[^\"\n]*\")+(?!\"))?+[^\"\n;]*+\"?[^\"\n;]*);.*", flags=re.MULTILINE)
test_str = ("Peekaboo ; A comment starts with a semicolon and continues till the EOL\n"
"Unless the semicolon is surrounded by dquotes \"Don’t do it ; here\" ;but match me; once\n"
"Im not surrounded \"so pay attention to me\" ; \"peekaboo\"\n"
"Im not surrounded \"so pay attention\" to;me\" ; \"peekaboo\"\n"
"Im not surrounded \"so pay attention to me ; peekaboo\n"
"Dquote escapes a dquote so \"dont pay attention to \"\"me;here\"\" buster\" do it ; here\n"
"Don’t pay attention to \"\"\"me;here\"\"\" but do \"\"it;here\"\" \n"
"and \"dont do \"\"it;here\"\"\" either ;peekaboo\n"
"but \"pay attention to \"it;here\"\" ;not here though\n"
"Simon said \"I like goats\" then he added \"and sheep;\" ;a good comment is \"here\n"
"Simon said \"I like goats\" then he added \"and sheep;\" dont do it here\n"
"Simon said \"\"I like goats;\"peekaboo\n"
"Simon said \"I like goats;\"\"peekaboo\n\n"
"\"\"I like goats;\"peekaboo\n"
"\"I like goats;\"\"peekaboo\n\n"
"\"aaa ; bb\"")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)