package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<p id="nav">)\s?(.*?)\s?(<\/p>)`)
var str = `<p id="nav">
<a href="http://tenupclp.dev/wp-login.php?action=register">Register</a> | <a href="http://tenupclp.dev/wp-login.php?action=lostpassword">Lost your password?</a>
</p>`
var substitution = "$1fart$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}