import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "LLPart1:(.*?)LLPart2";
final String string = "BundleFormat: 1\n"
+ "Name: TestIllegalStringsLintalist\n"
+ "Description: Created just to see what strings Lintalist uses\n"
+ "Author: Gurlan Vasile\n"
+ "TitleMatch: .txt\n"
+ "Patterns:\n"
+ "- LLPart1: [[Calendar=]]\n"
+ " LLPart2: >>date\n"
+ " LLKey: \n"
+ " LLShorthand: >>calendar\n"
+ " LLScript: \n"
+ "- LLPart1: Syntax:\n"
+ "__multilinevar --> create multiline variable\n\n"
+ "Notepad++:\n"
+ "__lngAuto --> Notepad++ : change language to Autohotkey\n\n"
+ "AHK Studio:\n"
+ "__refresh --> AHK Studio : refresh project\n\n"
+ "Other:\n"
+ "__tgs --> any editor : paste tags template\n"
+ "__newcode --> any editor : create code for Lintalist to be displayed properly\n"
+ "__lintalist --> any editor : create code for Lintalist to be displayed properly\n"
+ " LLPart2: \n"
+ " LLKey: \n"
+ " LLShorthand: >>>?\n"
+ " LLScript: \n"
+ "- LLPart1: messagebox show\n"
+ " LLPart2: \n"
+ " LLKey: \n"
+ " LLShorthand: \n"
+ " LLScript: MsgBox, Test\n"
+ "- LLPart1: wfaw\n"
+ " LLPart2: fwa\n"
+ " LLKey: \n"
+ " LLShorthand: \n"
+ " LLScript: \n"
+ "- LLPart1: some code here\n"
+ " LLPart2: some descriptive text here\n"
+ " LLKey: \n"
+ " LLShorthand: smcd\n"
+ " LLScript: msgbox, HelloWorld\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}