$re = '/<([^\/][a-z1-6]*)\s?(.*?)>|<\/([^&]*?)>/';
$str = '<a href="https:www.this.that.com">Word</a><aaa style='color:orange;'>Somethingelse</aaa><b>Another bit of something</b you=can\'t put attributes on an end tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);