import re
regex = re.compile(r"^\(?\d{3}\)?\-?\d{3}\-?\d{4}$", flags=re.MULTILINE)
test_str = ("999-999-9999\n"
"(123)123-1454\n"
"1234567890\n"
"(123)1231234\n"
"a122-123-1234\n"
"(123)-123-12345\n"
"(123)-(123)-(1234)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")