#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<([^ ?]+).*>((?=[^<]*• )[\w\W]+)<\/(\1)>"
Local $sString = "<p class="bodytext">" & @CRLF & _
" • This is some random text.<br>" & @CRLF & _
" • This is some other random text.<br>" & @CRLF & _
" • This is another random text." & @CRLF & _
"</p>"
Local $sSubst = "<ul>\2</ul>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)