import Foundation
let pattern = #"<([^ ?]+).*>((?=[^<]*• )[\w\W]+)<\/(\1)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p class="bodytext">
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<ul>\2</ul>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)