package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)BEGIN:VEVENT DTEND;VALUE=DATE:(.*?) DTSTART;VALUE=DATE: (.*?) UID:(.*?) SUMMARY:(.*?) END:VEVENT`)
var str = `BEGIN:VCALENDAR PRODID;X-RICAL-TZSOURCE=TZINFO:-//Airbnb Inc//Hosting Calendar 0.8.8//EN CALSCALE:GREGORIAN VERSION:2.0 BEGIN:VEVENT DTEND;VALUE=DATE:20221105 DTSTART;VALUE=DATE: 20220831 UID:6fec1092d3fa-a701f68d2829d331bc90b193830d447d@airbnb.com SUMMARY:Airbnb (Not available) END:VEVENT BEGIN:VEVENT DTEND;VALUE=DATE:20230103 DTSTART;VALUE=DATE:20221227 UID:6fec1092d3fa-e3596dc423d3ebfc6717c45d59f237ec@airbnb.com SUMMARY:Airbnb ( Not available) END:VEVENT BEGIN:VEVENT DTEND;VALUE=DATE:20230311 DTSTART;VALUE=DATE:20230212 UID:6fec1092d3fa-db18d3df7f07179688122eb867e2e274@airbnb.com SUMMARY:Airbnb (Not available) END:VEVENTDATE BEGIN:VEVENT= DTEND :20230903 DTSTART;VALUE=DATE:20230701 UID:6fec1092d3fa-de03b88cfd4d214ed4890da8da3a3541@airbnb.com SUMMARY:Airbnb (Not available) END:VEVENT END:VCALENDAR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}