$re = '/[force]at/m';
$str = 'A fat cat doesn\'t eat oat but a rat eats bats.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);