package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"\s*([#:].+?)\s*"`)
var str = `"#sql/inline"
":username"
"test"
" #sql/inline"
" :username"
" test"
" #sql/inline "
" :username "
" test "`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}