re = /([A-Za-z][A-Ha-hK-Yk-y]?[0-9][A-Za-z0-9]? ?[0-9][A-Za-z]{2}|[Gg][Ii][Rr] ?0[Aa]{2})/m
str = '1 Test Street
Test Town,
AA1 1AA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end