$re = '/(?:(HelloWorld:\w*)\(.*?\))/m';
$str = 'M:HelloWorld:main(java.lang.String[]) (S)HelloWorld:foo()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);