re = /(?:(HelloWorld:\w*)\(.*?\))/m
str = 'M:HelloWorld:main(java.lang.String[]) (S)HelloWorld:foo()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end