// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ui)(.+?),\s\d{6},\s(\d{1,2}\.\d+),\s(\d{1,2}\.\d+)").unwrap();
let string = "Богоявленский пер., 3с2, Москва, Россия, 109012, 55.75658286166606, 37.62422561645508
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}