$re = '/^([+-]?\d+)(\.\d+)?$/m';
$str = '29989773.23
29989773.2.33
299897.7377';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);