# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{2,6})[\s\D]*([0-9]{1,6})[\s\D]*((20){0,1}([0-9]{2}))$"
test_str = ("pagamento fattura 003235 2071/2022\n"
"pagamento fattura 003235/cli 2071/2022\n"
"pagamento fattura 003235-cli 2071-2022\n"
"pagamento fattura 003235 2071-2022\n"
"pagamento fattura 003235 cli 2071 2022\n"
"pagamento fattura 003235 2071 2022\n"
"pagamento fattura 003235 2071 del 20/12/2022\n"
"pagamento fattura cliente 003235 nr. 2071 del 20/12/2022\n"
"pagamento fattura cliente 003235 nr. 2071 del 20/12/22")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.