package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+d|[\w$:0-9`<>=&;?\|\!\#\+\%\-\s\*\(\)\.ÅÄÖåäö]+`)
var str = `AA,$,DESCRIPTION(Sink, clinical),$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}