using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[([^\]]+)\])";
string substitution = @"";
string input = @"[fdsfs,fds,fds][gdsfgfds,gdsgsdg,sdgsd]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}