const regex = /(\d{2})\s(?:(\d{3})\s)?(\d{7,10})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2})\\s(?:(\\d{3})\\s)?(\\d{7,10})', 'g')
const str = `63 240 1234567
63 1234567`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}