using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{1,4}-[0-9]{1,4}:\s(\w*)(\((\w+)\))?:\s(.*)$";
string input = @"AAAA-12: fix(test): fixed the failing test
AAAA-12: fix: fixed the failing test
AAAA-12: fix(): fixed the failing test
AAAA-12(): fix: fixed the failing test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}